Remote deploy authentication issue

Jul 2, 2008 at 7:39 AM
Hi,

I'm developing on a virtual machine that I run on my local host. I then have SDC based scripts that builds the solution. As long as I'm on my development machine everything works fine. When I however try to build to the test server things start to break. In the below example I've used a domain user that's a admin user and runs the BizTalk process on test.

<BizTalk2006.Application.Exists
    Application="MyApplication"
    Server="xxx.xxx.xxx.xxx"
    Database="BizTalkMgmtDb"
    UserName="
domain\DomainUserOnTheTestmachine?"
    Password="PasswordForTheAboveUser"
>
    <Output TaskParameter="DoesExist" PropertyName="ApplicationExists" />
</BizTalk2006.Application.Exists>

When I however examine the event viewer on the test machine I see a Failure Audit log event showing on the user that runs the process on my development machine and not the user I defined in the script (doesn't matter if I define a local user on the test machine or a domain user, it's still the user running the build script). I use Check Point VPN to authenticate myself to the server.

My feeling right not is that the username and password doesn't get sent ...  I'm sure that isn't the case but what am I missing here ...

I've also posted the same question here: http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=3557548&SiteID=1

Thanks in advance!

Richard

Developer
Jul 4, 2008 at 5:08 PM

Hi Richard, I believe Greg.Forsythe has answered your question in the post you included above. Let me know if you still have any issues.<o:p></o:p>

Mike

Jul 10, 2008 at 9:32 AM
Edited Jul 10, 2008 at 11:50 AM
Hi Mike,

I've now placed the development machine from which I'm running the script inside of the domain. Then everything works fine as long as I run with integrated security. As soon as I try and use the Password and UserName parameter and impersonate as another user I get into trouble and the user I use can't login.

Do people actually run the script under impersonation remote and what kind of permissions would I then need on the remote machine? I basically can't get it to work even when using the domain user I use for running the BizTalk instances!

I've also looked here and when reading the remarks section it looks like BtsCatalogExplorer only supports integrated security

The connection string is of the form "Server=svrname;Database=BizTalkMgmtDb;Integrated Security=SSPI".
Changing the connection string changes the object to point to the database represented by the new connection string.


Now when looking at the code in BizTalkInstallation.cs and the GetConnectionString method it look for a UserName and if i got one it will not use integrated but use SQL login. Will that ever work considering that BtsCatalogExplorer library does not seem to support it?

Thanks in advance!

Richard
Developer
Jul 17, 2008 at 7:38 AM
Hi Richard

The BtsCatalogExplorer does indeed only support integrated security. I'm not sure why SQL authentication was provided. The documentation and code will be revised in a future build. I will open a work item.

Thanks for raising this and apologies for the problems it has caused you.

Mike